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Swiss PDB Viewer (now Deep View) – in a simple manner 

 
Swiss-PDB Viewer is an application that provides a user friendly interface allowing to 
analyze several proteins at the same time. The proteins can be superimposed in order 
to deduce structural alignments and compare their active sites or any other relevant 
parts. Amino acid mutations, H-bonds, angles and distances between atoms are easy 
to obtain.  
 
1: Double click the icon named Spdbv in the desktop.  

Spdbv.lnk  
Observation……………………………………………………………………………………………………………. 
 
2. Go to the File menu, click Open PDB File. Select the data file for the H2O molecule 
Observation……………………………………………………………………………………………………………. 
 
3: Now click on the icon show below. Then drag the mouse inside the dark window, 
keeping the left button pressed. 

 
Observation……………………………………………………………………………………………………………. 
This is the translation tool. 
IMPORTANT!!! Look at the following message area of the spdbv window, for 
timely messages. 

 
 
4: Position the water molecule to the right end of the black window area (use the above 
icon). Now click the icon shown below. 
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Now position the water molecule at any place in the dark window area and click the icon 
shown above. Do it 2 or 3 times.  
Observation……………………………………………………………………………………………………………. 
 
This is the centralizing tool. 
 
5: Click on the icon show below. Then drag the mouse inside the dark window, keeping 
the left button pressed. 

 
Observation……………………………………………………………………………………………………………. 
This is the zooming tool. 
 
6: Click on the icon show below. Then drag the mouse inside the dark window, keeping 
the left button pressed. 

 
Observation……………………………………………………………………………………………………………. 
This is the rotation tool. 
 
7: Now click on the icon show below. Then click on the two Hydrogen atoms 

 
Observation……………………………………………………………………………………………………………. 
 
8: Click on one of the Hydrogen atoms. Then click the oxygen atom 
Observation……………………………………………………………………………………………………………. 
 
9: Go to the File menu and select the Close option. 
Observation……………………………………………………………………………………………………………. 
 

10. Open the data file for H2O molecule. Click the icon shown below. Then click on the 
oxygen atom, now on the two hydrogen atoms one after another.  

 
Observation……………………………………………………………………………………………………………. 
 

11. Now click on the icon show below. Then click on all the atoms in the molecule one by 
one. Look at the message area after each click. 

 
Observation……………………………………………………………………………………………………………. 
……………………………………………………………………………………………………………………………… 
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12. Select the File->Close…Option. 

Observation……………………………………………………………………………………………………………. 
 
IMPORTANT:- Always Close the previous molecular data file before opening the new 
molecular data file. 
EXERCISE 
 

13. Open the data file for H
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2SO molecule and find the following:- 4 

Bond distance (S-O bond):-……………………………………………………………………………………. 
Bond distance (O-H bond):-……………………………………………………………………………………. 

   Bond angle (all the bonds):-……………………………………………………………………………………… 
 ……………………………………………………………………………………………………………………………. 
 
14. Close the H2SO molecule. Now open data file of ammonia (NH4 3) and find out the 

following details: 
Find out:- 
Bond distance (all the three N-H bond):-…………………………………………………………………. 
……………………………………………………………………………………………………………………………. 

   Bond angle (all the three H-N-H bond):-…………………………………………………………………… 
 ……………………………………………………………………………………………………………………………. 
 
15. Open the data file for H2SO4 molecule. Click the following icon. 

  
 Now click on the Sulphur atom and any of the Hydrogen atoms. Look at the message 

area also. Then click on the arrow towards the right direction shown below.  

 
Observation………………………………………………………………………………………………………………. 
 
16. Close the H2SO4 molecule. Now click the Preferences menu and select the 

Colors…Option. Now click on the button for any of the atom name displayed. The 
following small window color shows the color for the selected atom. 

   
Now click on the OK button. Then check the default colors of all atoms, bonds, amino 
acid kind, structures, background etc… These colors will help us to identify different 
atoms present in a complex protein molecule. Last press the OK button…   
Observation……………………………………………………………………………………………………………. 
……………………………………………………………………………………………………………………………… 
 
17. Open the data file for the insulin molecule. Write down the possible atoms present 
in the molecule by looking at the colors. Rotate insulin and look at the complexity of the 
protein. 
Observation…………………………………………………………………………………………………………….  
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18. Select the window-> control panel…option.  
Observation…………………………………………………………………………………………………………….  
Points to note:- The control panel gives the information about insulin. On the top left, 
we have the protein name. 
 
19. Click the square named visible. 
Observation…………………………………………………………………………………………………………….  
 
20. Again click the square named visible. 
Observation…………………………………………………………………………………………………………….  
 
Points to note:- The column named group gives the names of amino acids present in 
the displayed protein.  The capital letters displayed on the left most part of the control 
panel shows the different parts of the protein. The letters present in between the capital 
letters and the group names gives information about α-helix (the letter h) and β-strands 
(the letter s).  
 
21. Scroll the mouse till you reach the end of the control panel area. How many different 
parts you found for insulin? 
Observation…………………………………………………………………………………………………………….  
 
22. Then write down the number of α-helix and β-strands present in each different part 
of the insulin. 
Observation: -  
Part A……………………………………………………………………………………………………………………. 
Part B…………………………………………………………………………………………………………………….. 
Part C……………………………………………………………………………………………………………………. 
Part D……………………………………………………………………………………………………………………. 
 
23. Now write down the names of the amino acids present in each of the α-helix and β-
strands present in insulin. 
 Observation:- Part A……………………………………………………………………………………………….. 
……………………………………………………………………………………………………………………………… 
Part B…………………………………………………………………………………………………………………….. 
……………………………………………………………………………………………………………………………… 
Part C……………………………………………………………………………………………………………………. 
……………………………………………………………………………………………………………………………… 
Part D……………………………………………………………………………………………………………………. 
……………………………………………………………………………………………………………………………… 
 
24. Now click on any of the letter A. What is your observation in the control panel and 
in the dark display area? 
Observation…………………………………………………………………………………………………………….  
 
25. Then write down the observations for the parts B, C and D.   
Observation…………………………………………………………………………………………………………….  
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Points to note:-  The letter v present in the column names show, side, labl 
represents “visible” . If v is not present it means “invisible”. 
 
26. Now select the part named A. Then click the column named show. 
Observation……………………………………………………………………………………………………………. 
 
27. Then click the column named labl. 
Observation……………………………………………………………………………………………………………. 
 
28. Now rotate the part of the molecule displayed. Click on the control panel menu.  
Observation……………………………………………………………………………………………………………. 
 
29.  Now click on any of the letter v present in the column named labl, keeping the 
SHIFT key pressed. 
Observation……………………………………………………………………………………………………………. 
 
30.  Now click on any of the letter v present in the column named side, keeping the 
SHIFT key pressed. 
Observation……………………………………………………………………………………………………………. 
 
31.  Now click on any of the letter v present in the column named show, keeping the 
SHIFT key pressed. 
Observation……………………………………………………………………………………………………………. 
 
31. Now click on the space corresponding to the first amino acid (here GLY1) of part A  
under the column named show.  
Observation…………………………………………………………………………………………………… 
 
32. Now click on the spaces corresponding to all the amino acids of part A. 
Observation…………………………………………………………………………………………………………. 
 
IMPORTANT:- Study how the amino acid residues connect each other by looking into 
the colors of the atoms. 
 
33. Now click on the space corresponding to each amino acid under the column named 
side, one by none. 
Observation………………………………………………………………………………………………………….. 
 
34. Now clear all the v under the column named side, following the similar steps done 
for the show column. 
Observation……………………………………………………………………………………………………………. 
 
35. Now click on the space corresponding to each amino acid under the column named 
labl, one by none. Last clear all the v under the column named labl. 
Observation………………………………………………………………………………………………………….. 
 
 36. Now display part A (without side & labl). Slightly rotate. Now click the column 
named ribn.    
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Observation………………………………………………………………………………………………………….. 
 
37. Clear all the v under the column named ribn. Now click on the column named υ. 
Observation………………………………………………………………………………………………………….. 
 
38. Display side chains also. Identify the change in the area of van der Waal’s effect. 
Clear all the v under the column named υ.  
Observation………………………………………………………………………………………………………….. 
 
IMPORTANT:- It displays the various van der Waal’s radii existing in the displayed 
molecule. 
  
Points to Note:- We can change the color of each amino acid by clicking on the small 
square shown corresponding to that amino acid under the  column named col. We can 
change the color of all or part of a molecule with the option select->all. We can remove 
the selection with the option select->none. 
 
39. Close the control panel & the display window of insulin. Now open the data file for 
insulin. Open the control panel also. Then go to the menu option Select-> Group 
Kind-> Gly (G).  Now click the column named show in the control panel. 
Observation………………………………………………………………………………………………………….. 
 
40. Now display all the Val (V) residues present in the insulin molecule. Count the 
number, label each one, and display the side chains also. 
Observation……………………………………………………………………………………………………………. 
 
41. Now go to the menu option select-> group property-> select basic amino 
acids. Now click the show column in the control panel.  
Observation……………………………………………………………………………………………………………. 
 
42. Now write down the names of each amino acids displayed in the above step. 
……………………………. …………………………………. ……………………………………… 
……………………………. …………………………………. ……………………………………… 
……………………………. 
 
43. Now check all the options in the select->group property menu (like acidic, polar 
etc). Each time click the show column in the control panel. 
Observation……………………………………………………………………………………………………………. 
 
44. Now go to the menu option select -> secondary structure -> strands option. 
Now click the show column in the control panel. Rotate to get a clear view. 
Observation……………………………………………………………………………………………………………. 
 
 
45. Now check the options of helices and coils present in select -> secondary 
structure menu option. Rotate to get a fine view. Last close the data file for insulin 
molecule. 
Observation……………………………………………………………………………………………………………. 
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EXERCISE:- 
Open the data file for Lysozyme. Find out the following:- 
Number of parts: - …………………………………………. 
Number of helices: - ………………………………………. 
Number of strands: - ……………………………………… 
Display only the helices: - ………………………............ 
Display both helices and strands (you can select both helices and strands by clicking, 
while keeping CTRL key pressed): - ………………………………………………………………… 
 
46. Open the data file for insulin. Go to the Edit -> Find Sequence… menu option. 
Now enter sequence FVNQ in the displayed text area & press the OK button. Then click 
the show column in the control panel. Also find out the names of matching amino 
acids. Last close the insulin molecule window. 
Observation……………………………………………………………………………………………………………. 
 
47. Now open the data file for insulin molecule. Then go to the Tools->Compute 
molecular surface… option.  
Observation……………………………………………………………………………………………………………. 
 
48. Now go to the File -> Discard -> Discard Surface…Option. 
Observation……………………………………………………………………………………………………………. 
 
49. Take the Tools-> Electrostatic potential… option. Now you select the values of 
the different parameters shown in the dialog box. Last click OK button. 
Observation……………………………………………………………………………………………………………. 
……………………………………………………………………………………………………………………………… 
 
50. Now go to the File -> Discard -> Discard Electrostatic potential…Option. 
Last close the data file for insulin molecule. 
Observation……………………………………………………………………………………………………………. 
 
51. Now open the data file for insulin molecule. Go to the Select-> All Option. Then 
go to the Window->Ramachandran Plot Option. 
Observation……………………………………………………………………………………………………………. 
 
IMPORTANT:- The Ramachandran Plot contains one small dot (actually a small 
square for glycines and a small plus sign for all others) for each selected residue (here 
we selected all the residues). When you place mouse over any of the dots, the name of 
corresponding amino acid will be displayed at top left corner of the plot. 
 
52. Now change the position of the dots present in the plot & look at the protein 
structure. 
Observation……………………………………………………………………………………………………………. 
 
52. Now show only ALA (A). Then display its Ramachandran plot. Change the position 
of the dots present in the plot. Last close the data file for insulin. 
Observation……………………………………………………………………………………………………………. 
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EXERCISE 
53. Open the data file for the Lysozyme. Show the Ramachandran plot for the whole 
molecule.  
Observation……………………………………………………………………………………………………………. 
 
54. Now show the plot for only VAL (V). 
Observation……………………………………………………………………………………………………………. 
 
55. Now go to Window-> Alignment option. 
Observation……………………………………………………………………………………………………………. 
 
Points to Note:- It shows the amino acid sequence of the insulin according to the 
order shown in the control panel. 
 
56. Now place the mouse over any of the letters in the alignment shown. 
Observation……………………………………………………………………………………………………………. 
 
57. Then click on any of the letters shown. Last close the data file of insulin. 
Observation……………………………………………………………………………………………………………. 
 
58. Now open the NOTEPAD and type the following in capital letters:- 

> MYSEQUENCE 
GHTESAARTNMKTGDDCGEQQASD Save the file as myseq.txt in the 
directory “c:\spdbv\". Close the notepad. Then go to SwissModel-> Load Raw 
Sequence to Model… option. Now select the file named myseq.txt and click 
Open. Rotate to get a nice view. 

Observation……………………………………………………………………………………………………………. 
……………………………………………………………………………………………………………………………… 
 
IMPORTANT:- The swiss PDB Viewer gives a possible helix corresponding to our raw 
sequence. Using this facility we can model the structure of a known sequence. 
 
59. Go to control panel and check whether the displayed structure is a helix or not. Now 
take the Alignment of the structure. Compare with our sequence.  
Observation……………………………………………………………………………………………………………. 
 
60. Display the Ramachandran plot for the displayed structure. 
Observation……………………………………………………………………………………………………………. 
 
61. Close the Ramachandran plot. Now open the data file for insulin, without closing 
the raw sequence structure. Then take the Window->Alignment option. 
Observation……………………………………………………………………………………………………………. 
 
IMPORTANT:- The vertical lines show exact match between the corresponding amino 
acid residues. The symbol “:” shows not exact match but in a similar group. “.” Tells 
that they are in dissimilar group.  You will get the rms value from the alignment 
window by, if you place the mouse over any letter of the raw sequence.  
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62. We can display each loaded molecule separately using the following area of the 
control panel. 

 
Now click on the label MYSEQ. 
Observation……………………………………………………………………………………………………………. 
 
63. Then click on the label insulin. 
Observation……………………………………………………………………………………………………………. 
 
64. Now go to File-> Close All Layers…option. Open the data file for insulin. Now 
click on the icon shown below. 

 
Then click on any of the amino acid residues present in the insulin.  
Observation……………………………………………………………………………………………………………. 
 
65. Now select any of the residue displayed. Look at the message area also. 
Observation……………………………………………………………………………………………………………. 
 
IMPORTANT:- The rotamer gives the possible staggered conformations of the 
selected side chain. The score value gives the score for the current conformation.   
 
66. Press the “*” key, present at the top right of the keyboard (NUMlock should be on), 
repeatedly and look at the selected side chain. Look at the message area for the values of 
rotamer and score. Last go to File->close…option.  
Observation……………………………………………………………………………………………………………. 
 
Points to Note:-  The green colored dashed lines shows the potential H-bonds. The 
pink colored dashed lines show the possible clashes.   
 
67. Open the data file for myoglobin. Now go to Color menu and study the options 
present there. 
By CPK: - ……………………………………………………………………………………………………………… 
By Selection: - ………………………………………………………………………………………………………. 
(Here you can combine this option with different Select-> Group…….options)   
 
68. Close the myoglobin molecule. Load the raw sequence myseq.txt (we already 
done). Now load data file for insulin. Now go to Fit-> Fit raw sequence…option. 
Centralize the molecule using the left most icon in the Toolbar. 
Observation……………………………………………………………………………………………………………. 
  
 
69. Now take the control panel. Click the column named show for both insulin and 
myseq (use label present at top left corner of control panel). Rotate the molecule for a 
better view. 
Observation……………………………………………………………………………………………………………. 
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70. Now display the alignment window and identify the fitting region. Use the scroll 
bar present in the alignment window. Last close the window for insulin. 
Observation……………………………………………………………………………………………………………. 
 
71. Open the data file for insulin. Now click on the icon shown below. Look at the 
message area also. Now click any atom. 

 
Observation…………………………………………………………………………………………………………… 
 
72. You can select various options shown including the radius of selection. The default is 
6.00 Angstrom. Now click the OK button. 
Observation…………………………………………………………………………………………………………… 
 
73. Now using the control panel display the whole insulin. Now click the icon shown 
below. Look at the message area also. Now click any atom. 

 
Observation…………………………………………………………………………………………………………… 
 
74. Now display the control panel. One amino acid residue will be in red color. Now click 
on the show column. 
Observation……………………………………………………………………………………………………………. 
IMPORTANT:- This shows the amino acid whose atom is selected by us. 
 
75. Display the whole insulin molecule using control panel. Now click on the icon shown 
below. Look at the message area also. Now click on any of the atom.  

  
Observation……………………………………………………………………………………………………………. 
IMPORTANT:- It displays the  Φ, ψ and ω angles. 
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