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HANDOUT #1 

 
Rasmol –  an easy approach 

 
RasMol is a visualization program created by Roger Sayle and used to display small 
molecules, proteins and nucleic acids. The name "RasMol" is derived from Raster (the 
array of pixels on a computer screen) .It is easy to use, runs on many platforms, is 
extremely powerful, and is free! The program can be used for analysis, display, teaching 
and generation of publication quality images. 
 
 
1: Double click the icon named Rasmol  in the desktop  

 
Observation……………………………………………………………………………………………………………. 
 
2: List the name  of the two window opened( You can see them on task bar at the bottom   
of the screen) 

……………………………….                ……………………………………………….. 
 
3: Write down the names of different Menus from the Menu Bar on top of the Rasmol 
version 2.6 Window (like File, Edit etc…) 
 
……………………………… ……………………………….. ………………………………….. 
……………………………… ……………………………….. ………………………………….. 
……………………………… 
 
4: Click the File Menu. Now you can see the menu options (like Open, Information  
etc…). Write down all the   menu options corresponding to the File Menu.  
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……………………………… ………………………………… ………………………………… 
……………………………… ………………………………… ………………………………… 
5. Click the Edit Menu. Now write down all the   menu options 
 
……………………………… ………………………………… ………………………………… 
……………………………… …………………………………  
 
6. Click the Display Menu. Now write down all the   menu options 
 
……………………………… ………………………………. ……………………………….. 
……………………………… ………………………………. ……………………………….. 
……………………………… ………………………………..  
 
7. Click the Colours Menu. Now write down all the   menu options 
 
……………………………… ……………………………….. ………………………………….. 
……………………………… ……………………………….. ………………………………….. 
……………………………… ……………………………….. 
 
 
8. Click the Options Menu. Now write down all the   menu options 
 
……………………………… ……………………………….. ………………………………….. 
……………………………… ……………………………….. ………………………………….. 
………………………………. 
 
9. Click the Expert Menu. Now write down all the   menu options 
 
……………………………… ………………………………… …………………………………… 
……………………………… ……………………………….. 
10. Click the Help  Menu, Now write down all the menu option 
 ………………………………         ………………………………… 
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11. Go to the File menu, click Open. Now a dialog box appears. ( Note that for this session 
your files are stored in C:\Rasmol directory.  For taking this from Open dialog box, 
double click on My Computer ->  C:  -> rasmol) 

 
 List the files available  
 
   ………………………………  ………………………………. ……………………………… 
   ………………………………  
 
12. From the dialog box, select the file with name H2O by clicking on it and then click 

Open. 
   Observation……………………………………………………………………………………………….  
 
13. Now  click the mouse on the screen and move it around  .  
   Observation …………….…………………………………. ……………………………………………………….. 
 ……………………………………………………………………………………….…………………………………… 
 
14 Now  right click the mouse on the screen and move it around without releasing it . 
     Observation…………………………………………………………………………………………………………… 

   ……………………………………………………………………………………………………………………………. 
 

15.Now Hold the shift key and the left mouse button to zoom 
  Observation…………………………………………………………………………………………………………….. 
   ……………………………………………………………………………………………………………………………… 
 
16.Now hold the shift key and press right button.  
  Observations……………………………………………………………………………………………………………. 
   ………………………………………………………………………………………………………………………………. 
   Note: It rotates on Z axis 
 
17: Select Display->Sticks, try to rotate by pressing the left mouse button and dragging 

mouse over the molecule 
   Observation…………………………………………………………………………………………………………… 
 
18.Select  Display-> Space fill , rotate the molecule 
  Observation………………………………………………………………………………………………………… 
 
19.Select  Display->Ball & stick, rotate the molecule 
    Observation…………………………………………………………………………………………………………… 
 
20.Select  Display->Wireframe, rotate the molecule 
   Observation………………………………………………………………………………………………………… 
 
21.Select  File->Information. Write down  the details provided 
   Observation…………………………………………………………………………………………………………… 
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22.Rasmol allows you to save the picture of molecule in different file formats. To save as a 
GIF file select Export->GIF. Now a dialog box appears. Type the file name ‘Mymolecule’  
and save in desktop. Minimize all  windows one by one. Double click the saved file.  Write 
down your observations 
 
…………………………………………………………………………………………………………………………………
…………………………………………………………………………………………………………………………… 
 
23.Try for other formats in the Export menu (BMP,EPSF,PPM,RAST) 
Observation………………………………………………………………………………………………………… 
…………………………………………………………………………………………………………………………………
…………………………………………………………………………………………………………………………………
………………………………………………………………………………………………………………………… 
 
 
24.Now we will use another molecule with a little bit more complex structure, a protein 
myoglobin. To open this first you have to close the already opened molecule. Select    
File->Close.  Now you open myoglobin using File->Open.You will get myoglobin from   
 c:\ rasmol 
Observation………………………………………………………………………………………………………… 
 
25.Try to rotate the molecule by pressing the mouse and dragging it 
……………………………………………………………….…………………………………………………………… 
 
26.Try all options in display menu. Write down the observation. 
 
……………………………………………………………….……………………………………………………………….

……………………………………………………………….……………………………………………………………….

……………………………………………………………….……………………………………………………………….

……………………………………………………………….……………………………………………………………….

……………………………………………………………….……………………………………………………………….

……………………………………………………………….……………………………………………………………….

……………………………………………………………….……………………………………………………………….

……………………………………………………………….………………………………………… 

 
27.Select Edit->Select All , even though you cannot observe anything in particular, all 
molecules are selected. Now we can change the colours options. 
 
28.Select Display->ball and stick . Now Select colours->monochrome 
 Observation…………………………………………………………………………………………………………… 
 
 
29.Select colours->CPK 
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 Observation…………………………………………………………………………………………………………… 
 
(CPK got some predefined colours for atoms Carbon: light grey ,Oxygen: red ,Nitrogen 
:sky blue ,Hydrogen :white ,Sulphur: yellow ,Phosphorous :orange ,Chlorine: green 
,Bromine and  Zinc: brown ,Calcium :dark grey ,Unknown :deep pink ) 
 
30.Select colours->Shapely 
 Observation…………………………………………………………………………………………………………… 
 
(Shapely: Coloured according to amino acid properties. ) 
 
31.Select colours->Group 
 Observation…………………………………………………………………………………………………………… 
(The chain is smoothly coloured from the 5’ to 3’ end. The colours follow the spectrum, 
blue, green, yellow, orange, and red) 
 
32.Select colours->Chain 
 Observation…………………………………………………………………………………………………………… 
(The structure is coloured according to chain identity.) 
 
33.Select colours->Temperature 
 Observation…………………………………………………………………………………………………………… 
(The structure is coloured according to temperature properties.) 
 
34.Select colours->Structure 
 Observation…………………………………………………………………………………………………………… 
(Structure: Coloured according to secondary structure, alpha helix = purple, beta sheet = 
yellow, turns = blue, other = white) 
 
35.Select  Display->Ball & Stick  to  change display style  of  the  molecule .  Now  select  
 Options->SlabMode,  A tick will appear in the menu. This mode is primarily useful for 
inspection of the interior portions of the molecule. Now hold down the control key,  press 
the mouse left button and drag it from left bottom to right top . The plane will pass 
through the molecule. Those atoms swept by the plane will disappear from the screen. Try 
this and write down your observation 
……………………………………………………………………………………………………………………………… 
………………………………………………………………………………………………………………………………. 
 
36.Now change the direction of mouse dragging (Hold down the control key) 
What is your observation? 
……………………………………………………………………………………………………………………………. 
……………………………………………………………………………………………………………………………. 
 
37.select  Options->SlabMode, to remove the tick mark 
 
Observation………………………………………………………………………………………………………………. 
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38.Select Options->Labels. A tick mark will appear in the menu. Zoom through the 
molecule by holding shift key and dragging mouse 
Observation………………………………………………………………………………………………………………. 
 
39.Select Options->Labels once again.  
 
Observation………………………………………………………………………………………………………………. 
 
40.Select Options->Stereo.  
 
Observation………………………………………………………………………………………………………………. 
 
41.Select Options->Stereo once again.  
 
Observation………………………………………………………………………………………………………………. 
 
42.Select Display->Spacefill ,then select  Options->Shadows.  
 
Observation………………………………………………………………………………………………………………. 
 
43.Select Options-> Shadows once again.  
Observation………………………………………………………………………………………………………………. 
 
Command Line 
 
Command line window is opened when you open the Rasmol. It is minimized and is on 
the task bar. Now click on command window. You can see a Rasmol command  prompt 
there. You can type in instruction there. Now right click on the taskbar and select Tile 
window vertically. You can see both window side by side. Close myoglobin and open  
Aspirin molecule. When using Rasmol before opening a second file ,you have to  close 
(File->close) the first file. For the following questions type in commands in command line 
window and press Enter key and observe the Rasmol display window to see the effects. 
Commands are shown in bold. 
 
44.background white 
Observation………………………………………………………………………………………………………………. 
 
45.select hydrogen 
colour blue 
Observation………………………………………………………………………………………………………………. 
………………………………………………………………………………………………………………………………… 
 
46.select hydrogen 
select Display->Spacefill from menu 
Observation………………………………………………………………………………………………………………. 
 
47.show information 
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Observation………………………………………………………………………………………………………………. 
Zoom the molecule using mouse and shift key 
 
48.reset 
Observation………………………………………………………………………………………………………………. 
 
49.label 
Observation………………………………………………………………………………………………………………. 
To see the effect Zoom in the molecule using mouse and shift key. Try to rotate. 
 
50.label off 
Observation………………………………………………………………………………………………………………. 
 
51.select oxygen 
spacefill 
Observation………………………………………………………………………………………………………………. 
 
52.select oxygen 
spacefill 1.7 
Observation………………………………………………………………………………………………………………. 
 
53.Try other real values 1.3, 1.4… 
Observation………………………………………………………………………………………………………………. 
 
54.select all 
spacefill off 
Observation………………………………………………………………………………………………………………. 
 
55.zap 
Observation………………………………………………………………………………………………………………. 
 
56.Now open Myoglobin(File->open) 
Observation………………………………………………………………………………………………………………. 
 
57.show sequence 
Observation………………………………………………………………………………………………………………. 
 
58.set solvent true 
    dots  
Observation………………………………………………………………………………………………………………. 
Van der Waals surface is shown 
 
59.dots off 
Observation………………………………………………………………………………………………………………. 
 
 
60.Hbonds 
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Zoom into the molecule and write down the observation 
………………………………………………………………………………………………………………………………… 
 
61.Hbonds off 
Zoom into the molecule and write down the observation 
…………………………………………………………………………………………………………………….………….. 
 
62.monitor 54 60 
zoom in and out and observe the molecule 
…………………………………………………………………………………………………………………….………….. 
 
63.monitor off 
…………………………………………………………………………………………………………………….………….. 
 
64.Backbone on 
Cartoon 100 
Observation………………………………………………………………………………………………………………. 
 
65. Ribbons 
Observation………………………………………………………………………………………………………………. 
 
66.Ribbons 150 
Observation………………………………………………………………………………………………………………. 
 
67.Ribbons off 
Observation………………………………………………………………………………………………………………. 
 
68.Trace 
Observation………………………………………………………………………………………………………………. 
(produces a spline of the alpha-carbon trace) 
 
69.Trace off 
Observation………………………………………………………………………………………………………………. 
 
70.Select backbone 
Colour red 
Observation………………………………………………………………………………………………………………. 
 
71.Select hydrophobic 
Spacefill 
Observation………………………………………………………………………………………………………………. 
 
72.select pro and not turn 
colour purple 
spacefill 0.25 
Observation………………………………………………………………………………………………………………. 
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73.Select 54, 100-105 
Observation………………………………………………………………………………………………………………. 
 
74.Select ala 
Colour green 
cartoon 
Observation………………………………………………………………………………………………………………. 
 
75.Select resno < 5 or resno > 40 
Colour blue 
Observation………………………………………………………………………………………………………………. 
 
76.Select within (3.0, as?)  
Observation………………………………………………………………………………………………………………. 
selects atoms within 3.0 Angstroms of Asp or Asn residues 
 
77.restrict within (3.0, as?)  
Observation………………………………………………………………………………………………………………. 
 
The restrict command will select a region and non-selected regions will no longer be 
shown in the representation. This is useful for examination of interior structure. To 
restore , select Edit->Select All, Display ->Wireframe, Colour->CPK 
 
78.set picking distance 
   Now click on the two atoms whose distance you want to measure. Observe the command 
window. 
Observation………………………………………………………………………………………………………………. 
 
79.set picking monitor 
   Now click on the two atoms whose distance you want to measure 
Observation………………………………………………………………………………………………………………. 
 
80.set picking angle 
   Now click on the three atoms whose angle you want to measure. Observe the command 
window. 
Observation………………………………………………………………………………………………………………. 
 
81.set picking torsion 
   Now click on the 4 atoms whose torsion you want to measure. Observe the command 
window. 
Observation………………………………………………………………………………………………………………. 
 
Use Lysozyme for the following(  Use File->Open) 
82.ssbonds on 
Observation………………………………………………………………………………………………………………. 
 
82.ssbonds off 
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Observation………………………………………………………………………………………………………………. 
(sulphur- sulphur bond) 
 
Script 
 
83.Open notepad and type in the following  
 

Zap 
Load "C:\rasmol\Lysozyme.pdb " 
select all 
spacefill 
Echo Press any key to continue 
Pause 
Exit 

Save as c :\ rasmol\yourscript.txt  
In command prompt type in 
 Script yourscript.txt 
Observations…………………………………..…………………………………..………………………………….. 
…………………………………..…………………………………..…………………………………………………….. 
Notes: 
Load filename: load a file 
Exit: terminates a script but not the RasMol session 
Echo: displays a message in the command line window 
Pause: pauses the script until a key is pressed 
Refresh: refreshes the screen 
 
 
84.You may use the save script command with script option to write out a script file that 
will reproduce the current image.  
 
 save script myscript.  
 
This will write a file named myscript in the RasMol directory.  Now change the display 
style as you like. Then give the following command 
 
script myscript  
Observation………………………………………………………………………………………………………………. 
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